This project is read-only.

Help on pushing changes to fork

Nov 15, 2010 at 5:32 PM

Hi, I just created a fork last week (ShowColumnNumber) and I have been trying to push all the change sets into the fork in the past week.  (I'm using the "synchronize" function in tortoiseHg). However, I always end up getting "the connection is actively disconnected by the remote host". I guess it's probably because it is a new fork and there are too many change sets I need to pull from the main branch and then push to my fork. Has any one encountered this problem before? Or am I doing the right thing?

My intention is to create a new fork, sync it with the main branch, apply my patch and submit it as several change sets. I am pretty new on this so any guidance would be very appreciated!


Nov 21, 2010 at 5:33 AM

Tried at a different place today. Still get the following error :S

<urlopen error [Errno 10054] An existing connection was forcibly closed by the remote host>[command interrupted]

Nov 21, 2010 at 8:34 AM


Did you watch at your fork by yourself? It is empty!

Just take a look at the other fork:, and then on yours:

I recommend you to delete this fork, and start again. When you create a fork using codeplex interface, it should be created correctly (it should not be empty). Seems like you are doing something wrong using TortoiseHg (after fork is created).

Also, I would suggest you learning more about Mercurial

Best regards,
Oleg Shuruev

Nov 22, 2010 at 2:23 AM

Hi, Oleg. I deleted the fork and tried "create fork" via codeplex website again.

The web form either gives me the following error:

The source control server is currently unavailable. Please try again later.

Did you create your fork via the codeplex website? Did I miss something? Thanks again for your help!

Nov 30, 2010 at 7:00 AM
Edited Nov 30, 2010 at 7:01 AM

Yes, forks are created via the codeplex website.

Maybe site was really unavailable at that moment. Have you tried to do it again?

Best regards,
Oleg Shuruev

Dec 28, 2010 at 9:55 PM
Edited Dec 28, 2010 at 9:56 PM

I'm seeing this same issue. I've tried creating a fork multiple times and while it gets created, it is always empty. The UI always returns an error that the source control server is currently unavailable.