<SourceFileList> does not work?

Mar 21, 2011 at 6:45 PM

Hi Everyone,

I tried to tell StyleCop do not check the Form1.Designer.cs file by adding the section below to Setting.StyleCop file which belongs to the solution but it did not work.

Do you see any problem with the way I do?

 

<StyleCopSettings>
<SourceFileList>       

        <SourceFile>Form1.Designer.cs</SourceFile>

        <Settings>

            <GlobalSettings>

                <BooleanProperty Name="RulesEnabledByDefault">False</BooleanProperty>

            </GlobalSettings>

        </Settings>

    </SourceFileList>

</
StyleCopSettings>


thanks,

Jdang


Coordinator
Mar 22, 2011 at 9:15 AM
Edited Mar 22, 2011 at 9:16 AM

In the Settings Editor select the C# node on the Rules tab. On the right Analyze designer files will be checked. Uncheck it and save the StyleCop.settings file (in the root of your solution or perhaps your project). For more details take a look at the docs at http://stylecop.codeplex.com/wikipage?title=Managing%20StyleCop%20Project%20Settings&referringTitle=Documentation