This project is read-only.

Upgraded from 4.4 to 4.5.16, doesn't run.

May 30, 2011 at 11:18 PM

I'm using StyleCop in a team setting having xcopied all the dll's and the settings and target to a folder next to the project: packages.external\StyleCop\v4.4

This have worked fine until I've upgraded to 4.5 and updated the csproj files.

First it only picked up the rules in the program files path, and when I uninstalled 4.5 it doesn't get picked up at all.

The target is registered in the csproj files and the StyleCop.Targets file is edited like so:

<UsingTask AssemblyFile="StyleCop.dll" TaskName="StyleCopTask"/>

No stylecop rules are being picked up anymore.

Jun 1, 2011 at 5:52 PM


Can you open a bug and attach the files and detail the configuration thats' not working please so i can investigate.

Jun 2, 2011 at 10:01 PM

Suddenly it started to work again. I think possibly that all the code was conformant to stylecop rules and that stylecop+ could have been blocked from explorer (not yet unblocked). I've downloaded it again and unblocked it as per the installation instructions.

However the settings editor worked, so I'm kind of stumped. Oh well. :)