Settings Editor

Nov 12, 2011 at 8:23 AM

I was using custom rules alongwith stylecop 4.3 and now moved to 4.6.3.  So Both rules were integrating. Now in 4.6.3 I'm not able to integrate my custom rules.

I have compiled my custom rules in vs2010 and targeted to dotnet 4.0. StyleCopSettingsEditor.exe is not showing my custom rules in editor other than standard rules. Not sure where I'm missing. I'm not sure whether following may be the issue. In second tab "Settings Files" first option is coming "Do not merge with any other settings files", while in earlier version it was coming as Merge with files in parent folder. Edit button is disabled. Not sure from where I need to control.

 

Developer
Nov 13, 2011 at 3:03 PM

Hi,

You should rebuild your rules over StyleCop binaries you are using (4.6.3).
They should be targeted to .NET 3.5, VS version is not relevant.

If everything is OK, you should see your rules in the editor.
The reason why you see "Do not merge..." is that you probably open the "root" settings file (placed in installation folder).

Just tell me if you need more help with this.

Best regards,
Oleg Shuruev

Nov 14, 2011 at 4:46 AM
Thanks Suruev!!
I have rebuilt our custom rules with latest 4.6.3 stylecop targetting 4.0.
You are right I was seeing in root folder but samething when I was seeing in root folder of stylecop 4.3 then I am able to see my custom rules in root folder when I open Stylecop.settings file in StyleCopSettingsEditor.exe.
Anyway I'm able to see my custom rules if I open on any project so it is solving purpose.

But I'm encountering another issue "SA0001 error" Null pointer exception in warning issued by 4.6.3 stylecop.
I could get link on this issue at http://stylecop.codeplex.com/discussions/212103 but not getting exact error point.
Any help on this is appreciated.


Regards,
Madhur

From: [email removed]
To: [email removed]
Date: Sun, 13 Nov 2011 08:03:47 -0800
Subject: Re: Settings Editor [stylecop:279191]

From: shuruev
Hi,
You should rebuild your rules over StyleCop binaries you are using (4.6.3).
They should be targeted to .NET 3.5, VS version is not relevant.
If everything is OK, you should see your rules in the editor.
The reason why you see "Do not merge..." is that you probably open the "root" settings file (placed in installation folder).
Just tell me if you need more help with this.
Best regards,
Oleg Shuruev
Read the full discussion online.
To add a post to this discussion, reply to this email (stylecop@discussions.codeplex.com)
To start a new discussion for this project, email stylecop@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com
Developer
Nov 15, 2011 at 5:47 PM

Hi,

Regarding settings editor - some bugs have been fixed since 4.3, so now its behaviour is correct.

What about "Null reference" exception - seems it is fired from your custom rules.
The only chance I could help you is that if you shared your custom rules source code anywhere so I could have a look.

Best regards,
Oleg Shuruev