StyleCop Fails to Load Custom Rules

Nov 15, 2011 at 8:59 AM

Hello, 

I'm running version 4.6.3.0

I have followed all the advise I have found on this site regarding failing to load custom rules assemblies into StyleCop. I have also tried downloading other peoples custom rules assemblies and they do not work either. 

Whats happening is that the custom rule does not appear in the tree view to the left in StyleCop settings GUI.

Things I've tried:

- .xml file is embedded resource

- the xml file has the same name as the class

- I target .NET Framework 3.5 (Any cpu)

- The custom rule assembly is placed into StyleCops default installation directory (same directory as the original rule assembly)

 

/Jonas

Developer
Nov 15, 2011 at 5:48 PM

Hi Jonas,

I could help you if you just shared your custom rules source code anyhow.

Best regards,
Oleg Shuruev

Nov 21, 2011 at 7:25 AM

Thank you Oleg, 

I just figured out what was the problem. The embedded XML resource had the wrong namespace (i think... at least now it works).

Best regards

Jonas