Resharper 6.1.37.86 and StyleCop 4.7.10.0 - no fixes or hints

Feb 14, 2012 at 12:33 PM

Can someone confirm the above combination should work? - in the previous versions of both Resharper (6.0) and StyleCop (4.6) I used to get the violation hints (the underline of problem code) and also when I hit the R# shortcut I got the stylecop fixes as options

With these latest versions I don't get any StyleCop assistance yet the plugin is reported in the options -> environments -> plugins and appears to have loaded ok

I've uninstalled and reinstalled both a couple of times with no change to the result

Any advice much appreciated

Richard

Coordinator
Feb 14, 2012 at 12:37 PM
Should work fine.

In the ReSharper options. Goto plugins.

Click the developer link at the bottom and see where the plugin is getting loaded from.

A.



On 14 Feb 2012, at 13:33, "gaspode44" <notifications@codeplex.com> wrote:

From: gaspode44

Can someone confirm the above combination should work? - in the previous versions of both Resharper (6.0) and StyleCop (4.6) I used to get the violation hints (the underline of problem code) and also when I hit the R# shortcut I got the stylecop fixes as options

With these latest versions I don't get any StyleCop assistance yet the plugin is reported in the options -> environments -> plugins and appears to have loaded ok

I've uninstalled and reinstalled both a couple of times with no change to the result

Any advice much appreciated

Richard

Feb 14, 2012 at 12:54 PM

Thanks for the quick reply - I checked the discovery information as you suggested and it indicated that the plugin was being loaded from a roaming profile stored on a network share - it looked like it loaded ok but I suspect it was failing to execute due to having been loaded from a share (its a fairly locked down environment here)

I copied it to a local path and it all sprang into life - only odd thing is its listed twice now in the plugins

 

Thanks again

Richard