This project is read-only.

R# 6.1.1000.82 & SC - no hints / fixes

Feb 23, 2012 at 10:43 AM
Edited Feb 23, 2012 at 10:47 AM


I used to have R# 5.1 with the old "Stylecop for Resharper". But, now that I have installed R# 6.1, StyleCop is no longer working inside Visual Studio. I don't have any hints/fixes.

I tried to uninstall Stylecop & R#, then reinstalled them both: it didn't help.

I tried to uninstall StyleCop & R#, deleted the Jetbrains folder from my Roaming folder, then reinstalled them both, but it didn't help either. It lost some settings, so I could click on the "Fix R# styles for StyleCop" (of something like this, I don't have the button anymore).

But I don't have any hint/fixes available.


If I go into the Plugins of R#, I can see that StyleCop is installed (and checked). And it is loaded from C:\Users\OmaR\AppData\Roaming\JetBrains\ReSharper\v6.1\Plugins\StyleCop 4.7\StyleCop.ReSharper611.dll

Which is the correct location, from my current user.


Edit: some more information:
I have Visual Studio 2005, 2008 & 2010 installed on my workstation. I installed R# on 2008 & 2010. And I use VS 2008.


Any help appreciated.



Mar 6, 2012 at 7:52 PM

Be sure that version of resharper plugin is I found that the installer does not update plugin for some reason. Plugin installed into c:\Program Files (x86)\JetBrains\ReSharper\v6.1\Bin\Plugins\StyleCop 4.7\ folder.

Mar 6, 2012 at 11:26 PM

I suppose you meant C:\Users\OmaR\AppData\Roaming\JetBrains\ReSharper\v6.1\Plugins\StyleCop 4.7\ ?

If this is the case, the StyleCop.ReSharper611.dll version is

I don't have any Plugins folder inside the C:\Program Files (x86)\JetBrains\ReSharper\v6.1\Bin folder

Mar 14, 2012 at 1:18 PM uploaded now. Please try and repro the issue in VS2k8.

Mar 14, 2012 at 1:32 PM

Doesn't work either with :(

Still nothing related to StyleCop inside the "Inspection Severity", and no hint/fixes

Mar 14, 2012 at 3:25 PM

I have just tried and it did not work for me either in VS2008. Same issue (no Inspection Severity options). I have a fresh installation of VS2005, VS2008, and VS2010, all with SP1 and latest updates.  R# 6.1.1000.82. The latest version that works for me in VS2008 is


Mar 14, 2012 at 9:20 PM

For those trying with 6.1.1000.82 and VS2k8 please install the debug build and please enable tracing described here ( and then zip and email the logs to andy at stylecop dot com. 

Mar 15, 2012 at 7:05 PM

Right. I think I have a good repro now.

Can someone check if you go to ReSharper->Options->Plugins and turn StyleCop off and then back on again that they appear please.


Mar 16, 2012 at 12:11 AM

Works fine! :)

But all the inspection severity for StyleCop are set to "Do not show", is there a way to quickly reset them to their default value?

Mar 16, 2012 at 9:28 AM

Spoke too quickly... each time I relaunch Visual Studio, I must turn off StyleCop then turn it back on, because it doesn't work right away...

Mar 16, 2012 at 9:33 AM
Edited Mar 16, 2012 at 1:20 PM

Fixed in - available now.