Are there any default rules that can not be deactivated?

Apr 2, 2012 at 12:46 PM

Hi there, 

I'm trying to get SVNStyleCop working on our SVNServer. I currently have a test-solution checked in (which I did before installing SVNStyleCop) and I am experimenting with that. SVNStyleCop is configured to only check my test-solutions path. This is working so far. 

For the first step of my installation, I would like to have one single "Settings.StyleCop" file in the StyleCop installation folder and make all my configuration there. 
For a first test I only activated the rule "SA1633: FileMustHaveHeader". 

My problem is, that no matter what rules I configure "on or off" in the "Settings.StyleCop" file inside of the StyleCop installation folder, I am unable to commit my changes. StyleCop always complains about rule violations for rules that I considered off, i.e. it says that "The method must have an access modifier. Line 10 in  /svnStyleCopTest/svnStyleCopTestSolution/svnStyleCopTestSolution/Program.cs" even though I explicitly deactivated this rule in the settings file.

I tried several combinations of having a "Settings.StyleCop" file around with my SVNStyleCop and StyleCop installations and even in some directories of my test solution, but none of them worked for me. 

I have "googled" for a clue to this issue several days now but found no solution.

Any help is appreciated. 

 

Thanks in advance,

 

ninjaCoder

Apr 2, 2012 at 2:09 PM

Sometimes a second pair of eyes helps... 

Thanks to hint from a colleague I was able to find the solution myself. After uninstalling StyleCop Version 4.7 and installing 4.3 everything worked perfect. It seems that 4.7 settings files are not compatible to the actual StyleCop Version. This seems to cause the use of a default configuration (where ever that comes from) which caused the above described behavior.

I hope this helps if someone has got the same problem.

 

Regards,

ninjaCoder

Coordinator
Apr 3, 2012 at 4:58 PM

Hi,

Not sure what you're actually seeing here. 4.7 will load an old 4.3 settings file and use it fine. If you edit a 4.3 compatible settings file with the 4.7 settings editor it will change the version number to '105' and have many new settings in it.

Apr 4, 2012 at 12:15 PM

Hi andy,

you're right. That's what I saw also.

My problem was, that SVNStyleCop seems to be compiled against StyleCop (file)version 4.3.1.3. When I changed the settings file that comes with SVNStyleCop (has a version number of 4.3 in it, I believe) with the editor of 4.7, SVNStyleCop would not use the settings any longer. 

I think I did not point that out clear enough. Sorry!

This is more an SVNStyleCop thing, anyway. Sorry for putting this here. I was not sure what exactly caused the problem.

 

Regards, 

ninjaCoder