This project is read-only.

Quick fixes for SA1633, etc missing?

Apr 27, 2012 at 1:07 AM
Edited Apr 27, 2012 at 1:35 AM

I'm using StyleCop version v4.7.1000.0 with Resharper version: 6.1.1000.82 (C# Edition)

A few versions ago, I used to get quick fix indicators for missing file headers (i.e. rule SA1633)

For the last couple of versions though (not sure how many unfortunately) I seem to have lost the quick fix prompts for all file header related rules (SA1633, SA1640, etc)

Have these been removed?

Or are my settings screwed up somewhere?

The rules themselves do work when I use the Run StyleCop function, but the quick fix has gone

(I've tried turning off merging of settings files in case it was a problem with a file I was not finding, but that doesn't bring them back either)

Thanks for any insights


More info - I tried breaking some more StyleCop rules, and I actually do not get any "shields" so I don't think I'm getting any StyleCop quick fixes!?! 

Apr 27, 2012 at 2:15 AM

In case it helps, it's loading the plugin dll (StyleCop.ReSharper611.dll) from :

...\AppData\Roaming\JetBrains\ReSharper\v6.1\Plugins\StyleCop 4.7\