This project is read-only.

StyleCop v4.7.19 not working in VS11

May 10, 2012 at 10:18 AM

I have installed StyleCop v4.7.19 which claims to be compatible with VS11 Beta, but it is not working. There are no StyleCop menu items / shortcuts appearing at all. I have tried un-installing and re-installing and still nothing. I have searched online but have had no luck with this. Has anyone else managed to get it working? Do I need to do anything other than simply install?

May 10, 2012 at 5:02 PM

Hi. If you use ReSharper then StyleCop runs in the background in VS11 beta. The menus are not yet fixed for VS11beta but they will be closer to the official release of VS11.

May 10, 2012 at 7:58 PM

I do not have ReSharper installed and I do not get the usual menu items showing up on Windows 8/VS11 beta. It worked on an earlier version about a month ago but not the current one I have installed (11.0.50327.1 PREREL).

May 10, 2012 at 8:00 PM

I guess MSFT have changed the menu'ing system between those versions of VS11 beta.

May 29, 2012 at 6:31 PM

4.7.27 working again on VS11 beta  (and R#7.0 daily build)