StyleCop settings within Resharper 7.0.x

Aug 10, 2012 at 2:25 PM

Does anyone know how to modify the StyleCop rule enforcement settings within R# 7.0?  The only reference to StyleCop that I can find in any of R#'s property pages is the one that allows you to enable/disable the plugin altogether.

Coordinator
Aug 10, 2012 at 2:36 PM
From memory

ReSharper Options (scroll down) Tools StyleCop


~A.

On 10 Aug 2012, at 14:25, jluckett79 <notifications@codeplex.com> wrote:

From: jluckett79

Does anyone know how to modify the StyleCop rule enforcement settings within R# 7.0? The only reference to StyleCop that I can find in any of R#'s property pages is the one that allows you to enable/disable the plugin altogether.

Aug 10, 2012 at 2:38 PM

Thanks, Andy!

That's where I thought it used to reside but StyleCop isn't showing up under my Tools section.  The plugin is enabled and I've tried rebooting, reinstalling both StyleCop and R#.

Any ideas?

Coordinator
Aug 10, 2012 at 2:53 PM
Assuming latest stylecop and rtm of r#7 it should be fine. Maybe you've an old version still installed somewhere?

Search machine for *.stylecop*.dll


~A.

On 10 Aug 2012, at 14:38, jluckett79 <notifications@codeplex.com> wrote:

From: jluckett79

Thanks, Andy!

That's where I thought it used to reside but StyleCop isn't showing up under my Tools section. The plugin is enabled and I've tried rebooting, reinstalling both StyleCop and R#.

Any ideas?

Sep 17, 2012 at 9:15 PM

Just wanted to confirm that I had installed Stylecop 4.7.0.36 and then Resharper 7.01 for VS 2012.  Had the same problem.

Uninstalled SC, installed 4.7.0.37, and now it seems to be working!