Customdictionary.xml in StyleCop install directory not being used

Sep 18, 2012 at 2:38 PM

I have placed my customdictionary.xml in the installation location for StyleCop (where the .dll file is per the help file instructions); however, StyleCop when run in Visual Studio is not using the dictionary.

I've trying placing it in other locations with no luck.  Is there a flag in the settings or something that tells StyleCop to use the dictionary?

Sep 18, 2012 at 3:29 PM

Was there a CustomDictionary.xml already in that folder? Did you overwrite it?

Sep 18, 2012 at 3:36 PM

There was one there already.  I changed the ACL on the file and added some Word entries to it.  However, I don't think it was ever being used as some of the words I was going to add were already in the file.

Sep 19, 2012 at 12:08 PM

We (I) had an issue in 4.7.37 where if you were in a 64 bit process it could load the spell checker. This is fixes in the next build. From 4.7.38 you can also add your own words into the Settings.StyleCop file with the settings editor.