This project is read-only.

Compatibility issues with R# 8.2.1 StyleCop

May 30, 2014 at 6:40 AM
I have upgraded to Resharper 8.2.1000.4556. And looks like this is not compatible with StyleCop or vice versa.

Is this a known issue?
Jun 3, 2014 at 3:15 PM
Every time R# is released it is an issue, would be nice if the guys at JetBrains would help out a bit on this project :\
Jun 3, 2014 at 4:01 PM
It would be nice, but I also don't think it's their responsibility to maintain StyleCop. JetBrains does have an early access program, which I assume could be used to have StyleCop updates ready to be released at the same time as R# updates.

I'd be more than happy to try to get into that program and keep StyleCop updated for all new R# releases, but not when pull requests take over a month to be accepted, I can't get a single response to any of my direct messages to Andy, and my discussion post asking about my direct messages to Andy gets deleted. This project needs a maintainer who is able to dedicate more time to it, but it doesn't look like that's going to happen any time soon.
Jun 10, 2014 at 3:30 PM
Looking forward to a new build as well.
Jun 12, 2014 at 10:32 AM
Take a look at the user page of Andy:

Last Visit: April 8, 2014
Jun 13, 2014 at 11:52 PM
This will probably be my last unofficial build, but can one or two others test this and confirm it works for them with R# 8.2.1: StyleCop-v4.7.821-Unofficial.msi
Jun 16, 2014 at 12:22 PM
Works for me. Test machine was Windows 7 SP1, x64, VS 2010.
Jun 18, 2014 at 11:45 AM

Works for me too. I have Windows 7 x86 - VS 2010, 2012.

  • Amul
Jun 18, 2014 at 12:00 PM
@csdahlberg that works great for me in vs 2013, thanks!
Jun 25, 2014 at 8:35 AM
It would be nice if the project were moved to github.
@csdahlberg, thanks for the working build.
Jul 3, 2014 at 7:55 PM
1 month bump?
Jul 26, 2014 at 10:03 AM
1 month bump?
Aug 18, 2014 at 2:30 PM
Has anyone experienced any issues using the @csdahlberg patch? I've been hesitant to upgrade both ReSharper & StyleCop.

Thanks, Rene.
Aug 25, 2014 at 11:31 AM
I haven't found any issues.
Aug 27, 2014 at 10:59 AM
I have been using since a month or so. No issues so far! :)

Is there an official release planned for this?
Aug 27, 2014 at 6:40 PM
I believe @andyr is the one who would be creating an official release. Since he still hasn't logged in since April 8th, I wouldn't hold my breath for one.
Aug 28, 2014 at 11:30 AM
His last activity is now more than 4 months ago. Do we consider this project as abandoned by him at some point? What will happen once there is a new release of ReSharper?
Sep 3, 2014 at 8:24 AM
csdahlberg: Is there any chance of one of your unofficial StyleCop builds for ReSharper 8.2.2 support? Huge thanks! :)
Sep 3, 2014 at 11:11 AM
I've just tried the official version with both 8.2.1 and 8.2.2, and it appears to be working fine. It's possible that in the upgrade from 8.2.0->8.2.1 and 8.2.1->8.2.2 that the plugin is deleted - it should live at ProgramFiles\JetBrains\ReSharper\v8.2\Bin\plugins\StyleCop 4.7\StyleCop.ReSharper800.dll, in which case, reinstalling or repairing StyleCop should replace the file. StyleCop also uses the old method of installing a plugin, rather than ReSharper 8's nuget based extension manager, so you won't see it listed in the Extensions Manager. However, you can confirm that it's installed and loaded by checking on the Plugins page of the Options dialog.

If the plugin still isn't working for you, can you let me know what issues you seeing?

Sep 10, 2014 at 3:08 PM
I was having the same issue. I fixed it by running the installer again, selecting "Change", manually enabling the R# integration (I assume this was disabled by default as it's not a supported R# version), then clicking through that "yes, I really do want to integrate with this unsupported R# version". It's all working fine now.